Delayed email delivery
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Nov 13, 2019 - 16:51 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2019 - 16:26 UTC
Identified
We are experiencing issues with email delivery. This may result in users not being able to access the Uphold Wallet due to delays in delivering the device verification email. Additionally new sign up confirm email and transaction confirmation may also suffer delays.
Posted Nov 13, 2019 - 16:11 UTC
This incident affected: API and Wallet.