Tezos (XTZ) - degraded performance on deposits and withdrawals

Incident Report for Uphold

Resolved

This incident has been resolved.
Posted Mar 29, 2023 - 22:57 UTC

Investigating

We are currently investigating this issue.
Posted Mar 29, 2023 - 19:23 UTC
This incident affected: Mobile Wallet, Web Wallet, and API.