Service Disruption: Solana withdrawals

Incident Report for Uphold

Resolved

This incident has been resolved.
Posted Nov 07, 2025 - 17:59 UTC

Investigating

We're experiencing delays processing Solana withdrawals affecting Uphold and Topper.

Our team is actively investigating to identify the root cause and restore normal operations as quickly as possible.

We’ll provide updates as soon as they become available.

Thank you for your patience and understanding.
Posted Nov 07, 2025 - 15:00 UTC
This incident affected: Deposits & Withdrawals and Topper.