Delay in processing XRP deposits
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Dec 23, 2021 - 21:44 UTC
Investigating
We are currently investigating this issue.
Posted Dec 23, 2021 - 18:12 UTC
This incident affected: Crypto (XRP).