All trading is currently halted
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Nov 24, 2020 - 13:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 24, 2020 - 13:05 UTC
Investigating
We are currently investigating this issue.
Posted Nov 24, 2020 - 12:48 UTC
This incident affected: Mobile Wallet and Web Wallet.