Service Disruption | XRP Deposits

Incident Report for Uphold

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 15:29 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 11, 2025 - 15:15 UTC

Identified

We’re currently experiencing an issue that is affecting most XRP deposits, due to a third-party service interruption.

Our team is actively monitoring the situation and working to restore full functionality as soon as possible.

We’ll continue to post updates here as more information becomes available.

Thank you for your patience and understanding. We apologize for any inconvenience this may cause.
Posted Jun 11, 2025 - 14:05 UTC
This incident affected: Deposits & Withdrawals.