Crypto trading is disabled
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Aug 22, 2020 - 17:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 22, 2020 - 17:12 UTC
Investigating
We are currently investigating this issue.
Posted Aug 22, 2020 - 16:34 UTC
This incident affected: API, Website, and Wallet.