Service Interruption | Certain Services Affected: KAS Deposits and Withdrawals

Incident Report for Uphold

Resolved

This incident has been resolved.
Posted May 14, 2025 - 08:57 UTC

Update

A partial fix has been implemented — withdrawals are now processing as expected.

Deposits are resuming and should return to normal processing times over the next few hours.

We’ll continue to share updates as more information becomes available.

Thank you for your continued patience and understanding. We apologize for any inconvenience caused.
Posted May 13, 2025 - 22:23 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 12, 2025 - 16:45 UTC

Update

We are continuing to investigate this issue.
Posted May 12, 2025 - 13:50 UTC

Investigating

We’re addressing a technical issue that’s temporarily impacting certain services on Uphold and Topper.

Affected Services:
- KAS Kaspa deposits and withdrawals

We're on it and expect to restore full service shortly.

We’ll post regular updates here as more information becomes available.

Thank you for your patience and understanding. We apologise for any inconvenience caused.
Posted May 12, 2025 - 13:47 UTC
This incident affected: Deposits & Withdrawals and Topper.