Temporary Service Disruption - USDC

Incident Report for Uphold

Resolved

This incident has been resolved.
Posted Mar 13, 2023 - 12:05 UTC

Investigating

Following the developments on USDC, we're experiencing intermittent issues with USDC liquidity and you may not be able to sell USDC temporarily.

Withdrawals are unaffected.

We're assessing the situation and will provide updates as they become available.
Posted Mar 11, 2023 - 11:20 UTC
This incident affected: Mobile Wallet, Web Wallet, and API.