Delayed DASH Transactions
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Aug 05, 2021 - 18:00 UTC
Investigating
We are investigating delays with DASH transactions. We apologize for any inconvenience as we work to resolve the issue as quickly as possible.
Posted Aug 05, 2021 - 13:20 UTC