We have identified an issue affecting our mobile app (Android and iOS) and Web, which is causing a delayed loading time. The security of your device is not affected and our team is working to resolve the issue.
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Apr 20, 2021 - 09:18 UTC
Investigating
We are currently investigating this issue.
Posted Apr 16, 2021 - 13:57 UTC
This incident affected: Mobile Wallet, Web Wallet, and API.