Deposits || USDC via Polygon network
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Jun 05, 2024 - 22:16 UTC
Identified
Due to an issue with a third-party provider, we're experiencing issues with USDC deposits via the Polygon network.

Your deposit may take longer than usual to process but, once the issue is resolved, we'll be able to complete it.

We are monitoring the issue and will provide updates as they become available.
Posted Jun 05, 2024 - 16:22 UTC
This incident affected: Deposits & Withdrawals.