Deposits & Withdrawals || Crypto Network

Incident Report for Uphold

Resolved

This incident has been resolved.
Posted May 01, 2024 - 09:25 UTC

Investigating

We're experiencing issues causing delays with Deposits & Withdrawals, via Crypto Network.

Your transaction may take longer than usual to process. Once the issue is resolved, we'll be able to process it.

Our team has already identified the issue and is working actively on a fix.

We apologise for the inconvenience.
Posted Apr 30, 2024 - 23:03 UTC
This incident affected: Deposits & Withdrawals.