Downtime || XDC network Deposits & Withdrawals
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Oct 03, 2024 - 19:37 UTC
Investigating
Due to an issue on the XDC network, we're experiencing issues processing XDC deposits and withdrawals. These transactions may take longer to process and/or fail.

We continue to investigate and monitor the situation and will provide updates as they become available.
Posted Oct 01, 2024 - 19:24 UTC
This incident affected: Deposits & Withdrawals.