Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 12, 2025 - 08:30 UTC
Scheduled
Scheduled: November 12, 2025, at 3:30 AM (EST) Expected Duration: Up to 30 minutes
We’ll be performing scheduled maintenance on our infrastructure.
During this window: - Crypto deposits and withdrawals will remain in Processing status and will be completed once maintenance is finished. - The Staking section will be temporarily unavailable. - There may be minor residual impacts on other features.
These changes will affect both Uphold and Topper platforms.
We appreciate your understanding and will provide updates as soon as they become available.
Posted Nov 11, 2025 - 15:22 UTC
This scheduled maintenance affected: Deposits & Withdrawals and Topper.