Service Currently Unavailable
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted 13 days ago. Oct 01, 2019 - 03:34 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 13 days ago. Oct 01, 2019 - 03:16 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 13 days ago. Oct 01, 2019 - 03:14 UTC
Investigating
We are currently investigating this issue.
Posted 13 days ago. Oct 01, 2019 - 02:52 UTC
This incident affected: API, Website, Wallet, and Deposits and Withdrawals.