UK FPS and SEPA instant deposits and withdrawals are delayed
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Jan 05, 2021 - 14:33 UTC
Identified
Incoming Instant SEPA deposits are still not being processed. Instant SEPA withdrawals and UK FPS deposits and withdrawals are working normally.
Posted Jan 05, 2021 - 14:11 UTC
Investigating
We are currently investigating this issue.
Posted Jan 05, 2021 - 11:03 UTC
This incident affected: National currencies (Euro, Pound Sterling).