Service Disruption | Topper

Incident Report for Uphold

Resolved

This incident has been resolved.
Posted Oct 01, 2025 - 19:52 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 01, 2025 - 19:34 UTC

Investigating

We’re experiencing an issue causing Topper to load slowly or fail for some users.

Our team is actively investigating and will provide updates here as they become available.

Thank you for your understanding.
Posted Oct 01, 2025 - 18:40 UTC
This incident affected: Topper.