Service Disruption || Uphold Wallet
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Oct 18, 2024 - 17:18 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 18, 2024 - 14:57 UTC
Investigating
We're experiencing issues with our services.

Wallet login and in-app services are affected so you may observe unexpected behaviours.

We are working on it and we'll provide updates as they become available.

Our apologies for the inconvenience.
Posted Oct 18, 2024 - 14:54 UTC
This incident affected: Mobile Wallet and Web Wallet.