Delays with XRP deposits and withdrawals
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Dec 23, 2021 - 10:22 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 22, 2021 - 17:44 UTC
Investigating
We are currently investigating this issue.
Posted Dec 22, 2021 - 16:44 UTC
This incident affected: Crypto (XRP).