Delayed BTC Withdrawals
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Mar 16, 2021 - 20:09 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 16, 2021 - 19:12 UTC
Investigating
We are investigating delays with BTC withdrawals. We apologize for any inconvenience as we work to resolve the issue as quickly as possible.
Posted Mar 16, 2021 - 18:39 UTC
This incident affected: Crypto (Bitcoin).