HBAR deposits and withdrawals disabled
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Mar 11, 2023 - 13:08 UTC
Investigating
HBAR has decided to temporarily shutdown network activity while they investigate an incident
Posted Mar 09, 2023 - 20:33 UTC
This incident affected: Mobile Wallet, Web Wallet, and API.