STORM Deposits/Withdrawals/Buys/Sells are unavailable
Incident Report for Uphold
Resolved
Contact our Support Team for more information about STORM.
Posted Jul 24, 2020 - 12:21 UTC
Update
We are continuing to investigate this issue.
Posted Jul 02, 2020 - 10:17 UTC
Update
Token Swap Technicality

You can read more about on the link below:

https://blog.stormtoken.com/token-swap-technicality-19211f23c9b9
Posted Jun 30, 2020 - 16:38 UTC
Investigating
STORM deposits, withdrawals, buys and sells are currently unavailable.
Posted Jun 09, 2020 - 21:17 UTC
This incident affected: Utility Tokens (Storm).