Delayed XRP Deposits and Withdrawals
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Nov 17, 2021 - 12:13 UTC
Investigating
We are investigating delays with XRP Deposits and Withdrawals. We apologize for any inconvenience as we work to resolve the issue as quickly as possible.
Posted Nov 16, 2021 - 19:45 UTC
This incident affected: Crypto (XRP).