DASH Deposits & Withdrawals
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Sep 14, 2022 - 16:44 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 14, 2022 - 16:44 UTC
Identified
We are unable to process DASH deposits and withdrawals via crypto network. We've identified the issue and are working on a fix.
Posted Sep 14, 2022 - 10:54 UTC
This incident affected: Crypto (Dash).