Mobile App loading issue
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Jun 22, 2020 - 12:29 UTC
Investigating
Our Mobile App is currently down, we expect to fix this issue shortly. Apologies for any inconvenience.
Posted Jun 22, 2020 - 11:53 UTC
This incident affected: Web Wallet.