Buys and sells of UPT are temporarily unavailable
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Aug 24, 2020 - 22:58 UTC
Investigating
Buys and sells of UPT are temporarily unavailable. Our team is investigating the issue and will have them restored as soon as possible
Posted Aug 24, 2020 - 22:14 UTC
This incident affected: Utility Tokens (Universal Protocol Token).