Delays processing DOGE withdrawals

Incident Report for Uphold

Resolved

This incident has been resolved.
Posted Feb 26, 2025 - 09:34 UTC

Investigating

Due to a third-party issue, we're experiencing issues with DOGE withdrawals.

Your withdrawal will show as "Processing" until this issue is resolved.

We expect to complete these withdrawals once the issue is fixed.

Updates will be provided as they become available.

We appreciate your understanding.
Posted Feb 25, 2025 - 15:21 UTC
This incident affected: Deposits & Withdrawals.