Delayed XRP withdrawals
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Dec 01, 2021 - 23:58 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 01, 2021 - 23:40 UTC
Investigating
We are investigating delays with XRP withdrawals. We apologize for any inconvenience as we work to resolve the issue as quickly as possible.
Posted Dec 01, 2021 - 20:38 UTC
This incident affected: Crypto (XRP).