LTC withdrawal delays
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 07, 2019 - 22:42 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 7 months ago. Mar 07, 2019 - 22:40 UTC
Identified
The issue has been identified and resolved for new LTC withdrawals. We will be releasing all withdrawals in a short time.
Posted 7 months ago. Mar 07, 2019 - 16:06 UTC
Investigating
We are investigating an issue regarding LTC withdrawals. As a result, all LTC withdrawals will be delayed for a short time. Apologies for any inconvenience.
Posted 7 months ago. Mar 07, 2019 - 14:42 UTC
This incident affected: Deposits and Withdrawals.