Metals buys and sells are currently disabled
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Apr 15, 2020 - 11:18 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 14, 2020 - 21:45 UTC
Investigating
We are currently investigating this issue.
Posted Apr 14, 2020 - 21:30 UTC
This incident affected: Website and Wallet.