Delay on ETH & ERC20 withdrawals.
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Feb 04, 2021 - 18:34 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 04, 2021 - 17:22 UTC
Investigating
We are currently investigating this issue.
Posted Feb 04, 2021 - 14:02 UTC
This incident affected: Mobile Wallet and Web Wallet.