Uphold Wallet not loading
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Jan 18, 2023 - 11:28 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 18, 2023 - 10:44 UTC
Investigating
Due to system issue the Uphold Wallet is not loading. This affects the App, Web Wallet and the Uphold Card.
We are investigating.
Posted Jan 18, 2023 - 10:30 UTC
This incident affected: Mobile Wallet, Web Wallet, and Uphold Debit Card.