Buys and sells are temporarily unavailable
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Mar 10, 2020 - 14:05 UTC
Monitoring
Fiat currencies trading has been reactivated and we are monitoring.
Posted Mar 10, 2020 - 13:26 UTC
Investigating
Fiat currencies buys and sells are temporarily unavailable. Our team is investigating the issue and will have them restored as soon as possible
Posted Mar 10, 2020 - 12:58 UTC
This incident affected: Web Wallet and API.