Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 15, 2025 - 09:30 UTC
Scheduled
Scheduled: January 15, 2024, at 9:30 AM (UTC) Expected Duration: Up to 2 hours
Deposits and withdrawals for all assets on the Ethereum network will be temporarily queued during this maintenance period. Transactions will display as “Processing” until maintenance is complete.
Posted Jan 13, 2025 - 15:31 UTC
This scheduled maintenance affected: Mobile Wallet, Web Wallet, Deposits & Withdrawals, API, and Topper.