Delayed DASH Transactions
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Sep 21, 2022 - 11:51 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 21, 2022 - 11:38 UTC
Investigating
We are investigating delays with DASH transactions. We apologize for any inconvenience as we work to resolve the issue as quickly as possible.
Posted Sep 15, 2022 - 17:08 UTC
This incident affected: Crypto (Dash).