Card Payments temporarily unavailable
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Jun 04, 2023 - 10:00 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2023 - 21:19 UTC
Investigating
Due to technical issues, our card payment feature is currently disabled. We apologize for the inconvenience. Please use a different card to perform payments.
Posted Jun 03, 2023 - 16:08 UTC
This incident affected: Mobile Wallet, Web Wallet, and API.