BTG deposits, withdrawal, sells and buys are currently disabled
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Jul 15, 2020 - 14:11 UTC
Investigating
We are currently investigating this issue.
Posted Jul 10, 2020 - 16:53 UTC
This incident affected: Crypto (Bitcoin Gold).