XAG trading temporarily disabled
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Sep 23, 2021 - 14:07 UTC
Investigating
We are currently investigating this issue.
Posted Sep 18, 2021 - 13:41 UTC
This incident affected: Metals (Silver).