Delayed ETH and ERC 20 Withdrawals
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted May 27, 2020 - 18:22 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 27, 2020 - 18:11 UTC
Investigating
We are investigating delays with ETH and ERC 20 withdrawals. We apologize for any inconvenience as we work to resolve the issue as quickly as possible.
Posted May 27, 2020 - 15:56 UTC