GBP Deposits via FPS || Transactions delay
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 10:09 UTC
Monitoring
GBP deposits are being processed normally.

We're monitoring to ensure that all previously pending deposits are processed.

We apologize for the inconvenience.
Posted Apr 25, 2024 - 11:46 UTC
Update
GBP deposited via the Faster Payments Service is taking longer than expected to credit to customer accounts, but will clear eventually.

We're investigating this issue and apologise for any inconvenience caused.
Posted Apr 25, 2024 - 01:19 UTC
Investigating
GBP deposits via Faster Payments Service are not being credited to customers as expected.

We're investigating this issue and apologize for any inconvenience caused.
Posted Apr 24, 2024 - 18:44 UTC
This incident affected: Deposits & Withdrawals.