We're experiencing delays on ethereum deposits
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Sep 17, 2021 - 16:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 17, 2021 - 16:08 UTC
Investigating
We are currently investigating this issue.
Posted Sep 13, 2021 - 11:56 UTC
This incident affected: Mobile Wallet, Web Wallet, API and Crypto (Ethereum).