Delayed ETH & ERC20 deposits & withdrawals processing

Incident Report for Uphold

Resolved

This incident has been resolved.
Posted Dec 19, 2022 - 21:19 UTC

Investigating

We are currently investigating this issue.
Posted Dec 19, 2022 - 18:09 UTC
This incident affected: Mobile Wallet, Web Wallet, and API.