Metals Trading Disabled
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted May 08, 2020 - 20:08 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 08, 2020 - 16:37 UTC
Investigating
We are currently investigating this issue.
Posted May 07, 2020 - 23:16 UTC
This incident affected: API, Website, and Wallet.