Disruption of service - ALBT
Incident Report for
Uphold
Resolved
NXRA airdrop and convertion performed.
Posted
Mar
15
,
2023
-
19:47
UTC
Investigating
ALBT activity is halted, this includes Trades, Deposits and Withdrawals.
More information available in our help center -
https://support.uphold.com/hc/en-us/sections/12589529752475-ALBT-Status
Posted
Feb
02
,
2023
-
18:33
UTC
This incident affected: Mobile Wallet, Web Wallet, and API.
×
Subscribe to Incident
Subscribe to updates for
Disruption of service - ALBT
via . You'll receive .