Instant USD Withdrawals maintenance

Incident Report for Uphold

Resolved

This incident has been resolved.
Posted Dec 02, 2024 - 04:24 UTC

Investigating

Instant USD Withdrawals to bank accounts are undergoing maintenance.
Posted Dec 02, 2024 - 01:00 UTC
This incident affected: Deposits & Withdrawals.