Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 29, 2026 - 08:00 UTC
Scheduled
Schedule: Thursday, January 29, 2025, starting at 03:00 AM EST (up to 15 minutes)
We’ll be performing scheduled maintenance on our identity services. During this time window: - Transactions and actions that require biometrics check will not be possible. - User onboarding flows that require address verification may be temporarily impacted. - Establishing a trusted session where a biometrics check is required will not be possible, which may affect login for some users.
Affected products: Uphold, Topper, Enterprise API, Ascent, and easyBitcoin.app
This maintenance is part of ongoing improvements to reliability and performance.
We appreciate your understanding.
Posted Jan 26, 2026 - 18:23 UTC
This scheduled maintenance affected: Mobile Wallet, Web Wallet, Topper, easyBitcoin.app, Ascent, and Enterprise API.