We're experiencing delays on bitcoin withdrawals
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Sep 14, 2021 - 15:37 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 14, 2021 - 12:13 UTC
Investigating
We are currently investigating this issue.
Posted Sep 14, 2021 - 11:05 UTC
This incident affected: Mobile Wallet, Web Wallet, API and Crypto (Bitcoin).