Price alerts push notification are being sent with delay, they may not reflect the current price - Please, trade carefully
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Feb 10, 2021 - 19:05 UTC
Investigating
We are currently investigating this issue.
Posted Feb 10, 2021 - 17:25 UTC
This incident affected: Mobile Wallet.