Delayed DASH Transactions
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted about 2 months ago. Jun 20, 2019 - 23:08 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 2 months ago. Jun 20, 2019 - 23:03 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted about 2 months ago. Jun 20, 2019 - 22:52 UTC
Investigating
We are investigating delays with DASH transactions. We apologize for any inconvenience as we work to resolve the issue as quickly as possible.
Posted about 2 months ago. Jun 20, 2019 - 22:26 UTC
This incident affected: Deposits and Withdrawals.